Support » Requests and Feedback » WordPress 5.4 – Add Image or Feature Image Opening in Same Window instead of pop

  • ofingo

    (@ofingo)


    Please help fix this major issue:
    After I updated wordpress sites to the latest version, When I click on add image or featured image, it open the upload image on same window. Thereby replacing the already opened add post or post editing. When you click on insert image, it open blank page.
    It shows the add image form URL instead of the post url you are working on at the backend, as it was before. Eg
    http://examplesite.com/wp-admin/media-upload.php?post_id=1366&type=image&TB_iframe=1

    instead of http://examplesite.com/wp-admin/post-new.php

    I have used Firefox browser, Chrome, Microsoft Edge but to no avail. I have tried the updated sites running on Cpanel, Plesk and even on other control panel by different web hosts but still the same

Viewing 3 replies - 1 through 3 (of 3 total)
  • In most cases, when this kind of thing happens, it’s some kind of conflict somewhere between WordPress core, your theme and your plugins.
    If you install http://wp101.net/plugins/health-check/ then it has a “troubleshooting mode” where you can experiment with how your admin pages behave with a standard WordPress theme and/or most of your plugins disabled. Then you can activate your plugins, one-by-one, all the time testing for this faulty behavior, until you find the culprit(s). The great thing about the health-check plugin is that it’s able to do this only in your browser session. I.e. any visitors to your website won’t notice any difference at all!

    If you want someone else to try and troubleshoot this problem, then much more information is needed (in order to replicate the problem):
    Which theme are you using? (and version)
    What plugins do you currently have active? (and versions)
    Which editor are you using (the Block Editor, the Classic Editor, or any kind of third-party “page builder”)?
    Can you describe, step by step, how you do this; where do you click, etc?

    ofingo

    (@ofingo)

    I am using Classic Editor, on some Block Editor. I think, the bug is not in any of the plugin used but a problem on WordPress core files.
    Because, I was unable to wait, I downgraded some of the sites to 4.9.8 and boom, it work fine again. I think, WordPress Development Team needed work on 5.4 and above

    When I try, using the latest version of WordPress, I’m not able to reproduce this problem. If there’s a bug in core, then we’d still need to first be able to reproduce the problem. So far, you’ve not provided enough information for that.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.